View Issue Details

IDProjectCategoryView StatusLast Update
0012018Dwarf FortressTechnical -- Saving/Loadingpublic2023-11-28 15:37
ReporterBD_Le_Dragon_Noir Assigned Tolethosor  
PriorityhighSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version50.03 
Fixed in Version50.11 
Summary0012018: Crash to Desktop on loading game during Loading Units phase
DescriptionGame has been running fine but now crashes on loading a save. This occurs on all saves for this world and occurs during the "loading units" phase of loading a game. An example save causing this issue can be found here:
Crash throws no obvious error - application just drops to desktop. Crash is repeatable on multiple saves and after reboot. Windows event viewer records an Error and Info item for the crash - Error event dump is as follows:

Faulting application name: Dwarf Fortress.exe, version:, time stamp: 0x639777b1
Faulting module name: Dwarf Fortress.exe, version:, time stamp: 0x639777b1
Exception code: 0xc0000005
Fault offset: 0x0000000000eeadb7
Faulting process ID: 0x25a8
Faulting application start time: 0x01d914ba0f82bb25
Faulting application path: D:\SteamLibrary\steamapps\common\Dwarf Fortress\Dwarf Fortress.exe
Faulting module path: D:\SteamLibrary\steamapps\common\Dwarf Fortress\Dwarf Fortress.exe
Report ID: c7fd6dc8-d296-40ad-9fd5-86578489cfc8
Faulting package full name:
Faulting package-relative application ID:
TagsNo tags attached.



2022-12-20 14:20

manager   ~0041448
closed&locked in Discord


2022-12-20 16:22

manager   ~0041465

Last edited: 2022-12-22 17:44

related *recent from Kertain discord user*


2022-12-23 13:58

viewer   ~0041524

Can confirm that this is happening still on v0.50.04. Here's my save:
The world was generated on v0.50.03. When I try to reload the older autosaves, the same issue happens sadly.
The error that appears to be generating at the end of errorlog.txt is "Unit has misaligned body modifiers. Adjusting.".


2022-12-23 14:00

viewer   ~0041525

Here's a save made in 50.03 that has this same problem as of 50.04


2022-12-24 05:42

viewer   ~0041553

I have the same error with loading my save as well. All four (auto save 1-3 + current) saves crash when attempting to load. The last save I was able to load was right before a siege and the appearance of some forgotten beasts and cavern dwellers.

Error log:


2022-12-24 12:13

viewer   ~0041554

The attached save WILL load, but when you wait until the human diplomat arrives (in just a few days), then save, and try to load the new save, it crashes while (according to the progress bar) processing unit data. If you don't quit after receiving the human diplomat, the game continues playing for as long as you'd like without a crash - but you can't save/reload ever again.
Version 50.04, Windows 10, no mods.


2022-12-26 15:37

viewer   ~0041563

Last edited: 2022-12-26 15:40

View 2 revisions

Also experiencing this issue. When loading a corrupted save I find it CTD's when "Loading Units" is occuring and errorlog produces the following:

"Creature caste outside of creature caste bounds: 1100 for toad with 2 caste(s)"

where the 1100 can vary wildly from 54 all the way up to 28286.

Following that is a varying number of lines with:

"Unit has misaligned body modifiers. Adjusting."

Unfortunately I don't have a recent save before the corruption occured, but the save I attempt to load which produces these results can be found here:

Version 50.04 -- Using only Audible Alerts, See-Through Designations, and Squad/Burrow Icon mods


2022-12-26 15:44

viewer   ~0041566

I have a similar issue except the save games can be loaded up to a certain point though I experienced random crashes before. Then I made a manual save file (one of many), quit and couldn't enter again. There is nothing in the error log but windows event viewer gives this:

Nazwa aplikacji powodującej błąd: Dwarf Fortress.exe, wersja:, sygnatura czasowa: 0x63a2a9ad
Nazwa modułu powodującego błąd: Dwarf Fortress.exe, wersja:, sygnatura czasowa: 0x63a2a9ad
Kod wyjątku: 0xc0000005
Przesunięcie błędu: 0x0000000000eff767
Identyfikator procesu powodującego błąd: 0x50d4
Godzina uruchomienia aplikacji powodującej błąd: 0x01d9198212b285bb
Ścieżka aplikacji powodującej błąd: D:\Program Files (x86)\Steam\steamapps\common\Dwarf Fortress\Dwarf Fortress.exe
Ścieżka modułu powodującego błąd: D:\Program Files (x86)\Steam\steamapps\common\Dwarf Fortress\Dwarf Fortress.exe
Identyfikator raportu: 156073c2-5f96-4e4d-8988-180a208c9d0c
Pełna nazwa pakietu powodującego błąd:
Identyfikator aplikacji względem pakietu powodującego błąd:

One of the broken saves:
I'm on 50.4 btw


2022-12-26 16:35

viewer   ~0041567

Same problem here, the "cave dwellers" save is a manual save I made when multiple cave dweller invasions happened, the save loads just fine. Over the next ingame year many more invasions and a forgotten beast appeared. Many corpses piled up during that time and the forgotten beast fought with the invaders as he had no valid way into my fortress. The beast somehow disappeared after taking one hit from an invader, no idea if he was actually killed or bugged away.
Anyways, the auto saves made in that time are corrupted and the "region6" save is the most recent save I made which is also corrupted, CTD on loading units with the given error log.
World was made arround 8.12.22 and I played without mods.


2022-12-27 13:51

viewer   ~0041570

Crashes when autosaving at the end of the winter (set your autosave to seasonal)
Removing file unit-4308.dat allows the autosave to proceed


2022-12-27 16:18

viewer   ~0041572

Crash to desktop
those 2 last saves:


2022-12-27 16:27

viewer   ~0041573

I also have this issue, crashes on "Loading Units" every time and deleting all but world.sav didn't help.

It is unmodded and I think saved in 50.03. I didn't notice the problem until updating to 50.04 though.

Save file:


2022-12-27 17:52

viewer   ~0041575

Last edited: 2022-12-27 17:53

View 2 revisions

In the archive is the second fortress in the world which is 17 years old (first created on release version, now on 50.04). Of all the save files is loaded only that in which I saved just before killing the forgotten beast (save file is called Bora). Also in the cave with this monster there is one cave-dweller who got stuck in the water after one of the attacks (it just swimming there for several years).


2022-12-28 05:55

viewer   ~0041581

Last edited: 2022-12-28 06:07

View 3 revisions

"Crash to desktop
those 2 last saves: "

so i can narrow this save corruption down to the huge amount of rodent men spawning on 20th slate and fighting the firebreathing fb there. the saves after that will get consistently corrupted. (the fb fighting isnt the cause, since it had many fights before that)
i uploaded a save right before that date. Im gonna try now to catch the fb and see if this changes a bit.

ok, i catched the fb, and the saves still get corrupted past this date..


2022-12-28 11:49

viewer   ~0041582

Here I've got some before and after save files that can be compared if that helps to identify the root cause.

The autosave ( loads fine.!Aqz-uFDCMw7hh688c8Do_ebCRZ-Zfg?e=qUyPbu

The main save file ( crashes on load. If it helps, there was a new forgotten beast that was generated since the auto-save, and every save since that point causes a crash, so maybe that relates?!Aqz-uFDCMw7hh689zu2xQW5CJcXzBA?e=tkjpXm


2022-12-29 08:44

viewer   ~0041584

Last edited: 2022-12-29 08:45

View 2 revisions

Same issue here, with similar entries in the error log.

Here's a zip file with the error log, an autosave from a few hours before the unloadable save (autosave 1) and the unloadable save (region1):


2022-12-29 13:19

viewer   ~0041587

Last edited: 2022-12-29 13:20

View 2 revisions

This appears to be related to cavern dwellers. See reddit thread here:

Reverting to an earlier autosave and turning cavern dweller scale and cavern dweller maximum attackers to 0 in custom difficulty settings allowed my fortress to get past the year/season where it was corrupting before.


2022-12-29 14:53

viewer   ~0041588

Also experiencing this (50.04).

Before (working) save:

After (broken) save from about 2 in-game weeks later:

In my case, seems to be related to an attack by animal people ("Cavern dwellers! Send them back to the darkness!") that always shows up sooner or later, so you can reproduce the bug live by loading the Before save, letting it run until the cavern dwellers attack, saving, and attempting to load.

Interestingly, saves appear to be broken starting a few days before the attack happens (once the attack happens, you know future saves will be broken, but recent past saves will also be broken). Bad units might be preloaded before the event triggers?


2022-12-29 18:04

viewer   ~0041589

Last edited: 2022-12-29 18:05

View 2 revisions

Unfortunately also encountered this bug in 50.04

My case is a bit different, as saves "before" don't get corrupted, only those that happen after dwellers attack. And it's also reproduceable in my case. As long as I don't encounter cave dwellers - saves are fine. But he moment I get the popup - save is doomed to be corrupted

So here's a working save:

And here's a broken one:


2022-12-30 01:03

viewer   ~0041592

Chiming in to confirm that the suggested workaround from the reddit thread linked above appears to have worked for me, after about a year's worth of gameplay (I was reliably getting save corruption events much sooner than that before disabling cavern invaders in difficulty settings).

Link to thread:


2022-12-30 17:59

viewer   ~0041593

I've also had this issue with my first two ever DF worlds. I have them both uploaded here:


2022-12-31 11:32

viewer   ~0041596

Same for me, played the fortress just fine yesterday and today the savegame is broken.
Game version is Premium V50.04, There was no new patch between the version I think


The second oldest autosave was loadable.


2022-12-31 15:11

viewer   ~0041597

Last edited: 2022-12-31 15:27

View 2 revisions

My save is also crashing on "Loading units". I created this fortress on the launch version. I played multiple times without this issue since the last patch. Fortunately my oldest autosave wasn't corrupted. IIRC there was a large cavern dweller invasion at some point. This is the first time I've had a corrupted save personally, and I've had seasonal autosave on this whole time.

Corrupted save (midspring year 262):
The last save before the corruption (early autumn 261):

Also I tried deleting everything besides world.sav in the corrupted save folder and it didn't help.


2023-01-01 11:27

viewer   ~0041599

My save is also crashing on loading units. I uploaded the most recent save at but all autosaves are doing the same. I had a few cavern invasions and a couple of forgotten beasts kicking around the caverns.


2023-01-02 07:37

viewer   ~0041603

Just to chime in for how widespread this is: I have also experienced what I think is this bug, it has been the death of several forts so far. It leaves no logs in the error file, and is 100% reproducible with an affected file.

My fort has some mods, however, so I don't know if that is more or less useful than other people's saves.


2023-01-02 14:23

viewer   ~0041604

Can confirm this is still happening in Version 50.04
Save: (errorlog + additional details in file description)


2023-01-03 17:28

viewer   ~0041607

Last edited: 2023-01-04 08:15

View 2 revisions

I just started seeing something similar on a 12-ish year-old fort. This save crashes to desktop on load:

This save from a month or so earlier works fine until spring starts, at which point I have the age of legends announcement and any further saves crash on load:


2023-01-04 18:17

viewer   ~0041619

Last edited: 2023-01-04 18:19

View 2 revisions

Another set of saves, vanilla Steam version with no mods

Corrupted save crashes during Load Units. Immediately after a FB appeared in the cavern, and shortly after a battle with invading reptile people

Intact save from about a year earlier

Error Log. Something to do with: Creature caste outside of creature caste bounds: 17741 for toad with 2 caste(s)
Unit has misaligned body modifiers. Adjusting.


2023-01-05 11:55

viewer   ~0041624

Last edited: 2023-01-05 13:17

View 4 revisions

Steam version v50.04. Windows 10. 64Gb RAM, 8Gb GPU.

region1 crashes on load, autosave1 (the previous save) works. The logs also show "Unit has misaligned body modifiers. Adjusting."!ApvbP7bE661HhBuDQIaEpYgsGnGk?e=kLv0xu

I also had a couple of FBs spawned. One was interacting with (e.g. slaughtering) some cave-dwellers ( CaveFish Men and others )

[EDIT] Fix confirmed! v50.05 allowed me to open a corrupted save ( "Unit has misaligned body modifiers. Adjusting." bug)


2023-01-05 12:23

viewer   ~0041625

I'm happy to say that after the v50.05 patch, the issue is fixed! All my old saves which would previously crash on loading units now load without a hitch :)


2023-01-05 13:12

viewer   ~0041626

This issue seems to have been resolved for my 2 broken saves both modded and unmodded as of v50.05.
Can anyone else confirm?


2023-01-05 13:18

viewer   ~0041627

Confirmed! :) My broken save ( is now loadable.


2023-01-05 14:41

viewer   ~0041631

As of version 50.05. I never had this crash before but now I do. Game crashes to desktop when attempting to load units.


2023-01-05 16:42

viewer   ~0041633

My saves are now loading!


2023-01-06 01:26

viewer   ~0041635

I am experiencing this in 50.05, and I wasn't previously.


2023-01-06 19:14

viewer   ~0041643

I'm still experiencing this in 50.05 crashes on loading units, no error message that I can see


2023-01-07 12:26

viewer   ~0041652

I just had this issue on 50.05. Crashes on "loading units". No forgotten beasts afaik, year 51, <30 dwarves.


2023-01-08 17:19

viewer   ~0041660

I'm having an issue loading the most recent/current save for my game on 50.05, it's getting stuck on Loading Army Units and then crashing to desktop after running out of RAM. Screenshot and world save provided below. The autosave a month or so before this current save seems to load fine.!ArhrVlLle88jjpMN7jhqk3f2mM2UoQ?e=Jjcxco


2023-07-05 07:41

viewer   ~0041813

any new about this? in version 50.09 stay crashing


2023-07-24 01:44

viewer   ~0041816

It's crazy that this has been occurring for almost 3 weeks, I've been trying to play this game and I can't seem to load in. I originally thought it was an issue with the resolution of my ultrawide monitor, but it seems that even with my normal monitor it still crashes.
Unfortunately even with the latest version on steam I'm still seeing this issue, and I'm going to refund the game since I literally cannot play it.
Steam support if your looking at my screenshot, this is me.


2023-11-16 11:54

manager   ~0041861

Posted by anonymous:

I am also experiencing this, since I've started playing the steam version. Crashlogs are some format of:

0> Dwarf_Fortress!std::_Init_locks::operator=+0x7F36F6
1> Dwarf_Fortress!std::_Init_locks::operator=+0x7F3869
2> KERNELBASE!UnhandledExceptionFilter+0x1E7
3> ntdll!memset+0x13B0
4> ntdll!_C_specific_handler+0x96
5> ntdll!_chkstk+0x11F
6> ntdll!RtlRaiseException+0x484
7> ntdll!KiUserExceptionDispatcher+0x2E
8> Dwarf_Fortress!std::_Init_locks::operator=+0x831AD
9> Dwarf_Fortress!std::_Init_locks::operator=+0x105FBC5
10> Dwarf_Fortress!std::_Init_locks::operator=+0x103881B
11> Dwarf_Fortress!std::_Init_locks::operator=+0x602EDC
12> Dwarf_Fortress!std::_Init_locks::operator=+0x5FA377
13> overlay_plug+0x7E5E
14> Dwarf_Fortress!std::_Init_locks::operator=+0x8FABC6
15> Dwarf_Fortress!std::_Init_locks::operator=+0x626DC4
16> Dwarf_Fortress!std::_Init_locks::operator=+0x628179
17> SDL2!SDL_DYNAPI_entry+0x799D7
18> SDL2!SDL_DYNAPI_entry+0x12EEDE
19> ucrtbase!configthreadlocale+0x92
20> KERNEL32!BaseThreadInitThunk+0x14
21> ntdll!RtlUserThreadStart+0x21


2023-11-27 08:08

manager   ~0041913

If you're still getting this, please upload your save--as of 50.11, the save that was originally posted **no longer crashes**, so if you're getting similar behavior, it's a **different bug**. Any unit corruption crash is going to look like this, so it's not a surprise that there might be new bugs that just happen to look the same.

Note that running out of RAM is not going to be the same bug either, and should be reported separately.


2023-11-28 15:37

manager   ~0041918

Resolving based on Putnam's comment. If your save still crashes, please open a new report and attach your save there. It's fine to reuse the same save you uploaded before, as long as it still crashes in the current version of DF. There are far too many unrelated saves attached here for us to sort through, some of which were fixed in older versions per comments, and since many were posted by anonymous users on the previous bug tracker, we unfortunately can't follow up.

Issue History

Date Modified Username Field Change
2022-12-20 14:19 BD_Le_Dragon_Noir New Issue
2022-12-20 14:20 BD_Le_Dragon_Noir Note Added: 0041448
2022-12-20 16:22 BD_Le_Dragon_Noir Note Added: 0041465
2022-12-21 05:27 BD_Le_Dragon_Noir Note Edited: 0041465
2022-12-21 06:49 BD_Le_Dragon_Noir Note Edited: 0041465
2022-12-22 17:08 BD_Le_Dragon_Noir Note Edited: 0041465
2022-12-22 17:14 BD_Le_Dragon_Noir Note Edited: 0041465
2022-12-22 17:44 BD_Le_Dragon_Noir Note Edited: 0041465
2022-12-23 13:58 anonymous Note Added: 0041524
2022-12-23 14:00 anonymous Note Added: 0041525
2022-12-24 05:42 anonymous Note Added: 0041553
2022-12-24 12:13 anonymous Note Added: 0041554
2022-12-26 15:37 anonymous Note Added: 0041563
2022-12-26 15:40 anonymous Note Edited: 0041563 View Revisions
2022-12-26 15:40 anonymous Note Added: 0041564
2022-12-26 15:40 anonymous Note Deleted: 0041564
2022-12-26 15:44 anonymous Note Added: 0041566
2022-12-26 16:35 anonymous Note Added: 0041567
2022-12-27 13:51 anonymous Note Added: 0041570
2022-12-27 16:18 anonymous Note Added: 0041572
2022-12-27 16:27 anonymous Note Added: 0041573
2022-12-27 17:52 anonymous Note Added: 0041575
2022-12-27 17:53 anonymous Note Edited: 0041575 View Revisions
2022-12-28 05:55 anonymous Note Added: 0041581
2022-12-28 05:56 anonymous Note Edited: 0041581 View Revisions
2022-12-28 06:07 anonymous Note Edited: 0041581 View Revisions
2022-12-28 11:49 anonymous Note Added: 0041582
2022-12-29 08:44 anonymous Note Added: 0041584
2022-12-29 08:45 anonymous Note Edited: 0041584 View Revisions
2022-12-29 13:19 anonymous Note Added: 0041587
2022-12-29 13:20 anonymous Note Edited: 0041587 View Revisions
2022-12-29 14:53 anonymous Note Added: 0041588
2022-12-29 18:04 anonymous Note Added: 0041589
2022-12-29 18:05 anonymous Note Edited: 0041589 View Revisions
2022-12-30 01:03 anonymous Note Added: 0041592
2022-12-30 17:59 anonymous Note Added: 0041593
2022-12-30 18:00 anonymous Note Added: 0041594
2022-12-30 18:00 anonymous Note Deleted: 0041594
2022-12-31 11:32 anonymous Note Added: 0041596
2022-12-31 15:11 anonymous Note Added: 0041597
2022-12-31 15:27 anonymous Note Edited: 0041597 View Revisions
2023-01-01 11:27 anonymous Note Added: 0041599
2023-01-02 07:37 anonymous Note Added: 0041603
2023-01-02 14:23 anonymous Note Added: 0041604
2023-01-03 17:28 anonymous Note Added: 0041607
2023-01-04 08:15 anonymous Note Edited: 0041607 View Revisions
2023-01-04 18:17 anonymous Note Added: 0041619
2023-01-04 18:19 anonymous Note Edited: 0041619 View Revisions
2023-01-05 11:55 anonymous Note Added: 0041624
2023-01-05 11:57 anonymous Note Edited: 0041624 View Revisions
2023-01-05 11:58 anonymous Note Edited: 0041624 View Revisions
2023-01-05 12:23 anonymous Note Added: 0041625
2023-01-05 13:12 anonymous Note Added: 0041626
2023-01-05 13:17 anonymous Note Edited: 0041624 View Revisions
2023-01-05 13:18 anonymous Note Added: 0041627
2023-01-05 14:41 anonymous Note Added: 0041631
2023-01-05 16:42 anonymous Note Added: 0041633
2023-01-06 01:26 anonymous Note Added: 0041635
2023-01-06 19:14 anonymous Note Added: 0041643
2023-01-07 12:26 anonymous Note Added: 0041652
2023-01-08 17:19 anonymous Note Added: 0041660
2023-07-05 07:41 anonymous Note Added: 0041813
2023-07-24 01:44 anonymous Note Added: 0041816
2023-11-16 11:54 nuvu Note Added: 0041861
2023-11-27 08:08 Putnam3146 Note Added: 0041913
2023-11-28 15:37 lethosor Assigned To => lethosor
2023-11-28 15:37 lethosor Status new => resolved
2023-11-28 15:37 lethosor Resolution open => fixed
2023-11-28 15:37 lethosor Fixed in Version => 50.11
2023-11-28 15:37 lethosor Note Added: 0041918