View Issue Details

IDProjectCategoryView StatusLast Update
0001451Dwarf FortressDwarf Mode -- Militarypublic2018-07-17 18:31
ReporterBlah Assigned Touser11 
Status confirmedResolutionopen 
Product Version0.31.03 
Summary0001451: Military equipment interferes with civilian equipment (picks/axes/crossbows/quivers)
Description1) A woodcutter can't use the same axe for woodcutting and military. When he is given a kill/station command, he will deposit his current axe and pick up some other weapon, completely ignoring the axe he deposited into a weapon stockpile. If there is no other suitable weapon he'll fight unarmed.

2) Possibly related to the above: if the woodcutter is holding an axe, the same axe won't show up in _his_ "assign specific weapon" list.
Steps To ReproduceEmbark with 2 axes (of different material to make things easier)
Assign woodcutting labor to a dwarf to get him to pick up 1 axe.
Make a weapon stockpile to hold the other axe.
Put the woodcutter into a squad and tell him to use axes in the equipment screen.
Forbid the axe in the weapon stockpile.
Give the woodcutter's squad a station command.
Observe the behaviour described earlier.

Cancel the station command, reclaim the previously forbidden axe, and give another station command.
This time the woodcutter will swap axes.

Additional InformationThis will probably also occur with hunters.

One time after repeated testing in the same embark, this bug stopped occuring. It could be that this can only occur early in the game for some reason.
TagsNo tags attached.


related to 0000535 acknowledgedToady One Equipping weapons/armor on military is erratic 
parent of 0002143 confirmeduser11 woodcutter drops complete assigned equipment if being undrafted 
parent of 0002127 new Picks stored in stock pile will not be equipped by those with mining job enable and mining area designated. 
parent of 0004062 resolveduser6 Hunters who are also in the military don't train or pick up equipment 
parent of 0004236 new Miner-Military will not discard old picks; 'cannot follow orders' 
parent of 0002959 new Equipment picked up to perform a job does not show on military screen. 
parent of 0010179 new Hammerer in squad does not use assigned weapon 
has duplicate 0001478 closeduser6 Dwarves drop proper weapon 
has duplicate 0000523 resolveduser6 Dwarf drops sword in order to pick up another 
has duplicate 0001693 resolveduser6 Farmer really likes his pick 
has duplicate 0002906 resolveduser6 Wood Cutters Behaving Oddly 
has duplicate 0009007 resolvedLoci Dwarves won't cut wood/conflict with Captain of the Guard 
has duplicate 0010228 resolvedLoci Dwarves in Squads Constantly Swapping Equipment 
related to 0000737 resolvedToady One Migrant hunters (with hunting labor enabled) haul their quiver to a stockpile and then pick up another one 
related to 0000680 new Picks are listed as (foreign) in the military equipment screens 
related to 0000110 resolvedToady One Migrant hunters/miners/woodcutters can arrive with labors disabled, causing them to drop equipment 
related to 0000340 new Dwarf repeatedly try to store job-based weapons in burrow-forbidden stockpiles 
related to 0000712 resolvedToady One Woodcutters cut trees with training axes 
related to 0001016 resolvedToady One Captain of the guard performs beating with combat weapon. 
related to 0005300 new "No weapon for execution" when Hammerer is in military squad 
related to 0008345 assigneduser6 hunters in the military stuck in equipment loop 
related to 0008961 confirmedLoci Off-duty military dwarves store food in bedrooms, get more, repeat 
Not all the children of this issue are yet resolved or closed.



2010-04-23 05:25

reporter   ~0004699

What I think is happening:
military positions are selecting equipment randomly from stocks.

embark with axes, lumberjacks. civilian woodcutters will take a (random) axe.
put woodsdwarves in axemen squad.
squad positions select again random (rather than closest to dwarf in positionX) axe.
activate squad. dwarf holds holds weapon claimed by other: drop axe. dwarf wants axe held by other dwarf: get axe.

If this is true, then this should work around the issue.
remove the woodcutter job from all dwarves, let dwarves drop and store axes.
assign axemen to squad, activate squad, let them collect equipment.
reactivate woodcutter job on conscripted axemen.
set squad to inactive alert.
civilians should now equip nearest axe (if lumberjack is first job in list)
The military incarnation's axe is fixed. Problems arise again if mil>civ drops axe.


2010-04-23 10:17

reporter   ~0004730

>> What I think is happening:
>> military positions are selecting equipment randomly from stocks.

This isn't random. I tested it about 10 times on different embarks while trying to understand what the root of the problem was. He always dropped his current axe (except at one point in one embark from which things started workign correctly for some inexplicable reason. It always worked correctly after that in that embark, but kept reoccuring in the next embarks)


2010-04-27 08:10

reporter   ~0005340

so... the dwarf swaps axe every time he/she switches from military to civilian status?


2010-05-15 10:09

reporter   ~0006728

Depends. When I was killing off a deer that had wandered into my fort, Urist McWoodcutter made short work of him with his axe. Then, a bear wanders by, and I try to preemptively kill him, and Urist McWoodcutter proceeds to drop his freaking axe and try to wrestle the bear.

"Urist McWoodcutter has bled to death"


2010-06-20 02:30

reporter   ~0008751

This also happens with miners who have been assigned picks.


2010-08-03 10:25


Briggs uploaded this save for 0002906:

Hieronymous Alloy

2010-09-14 09:37

reporter   ~0012633

I've had a problem that I believe is connected to this. I've noticed that I'll sometimes get military dwarves -- soldier icon, "axedwarf" or whatever profession name -- idling in my meeting area, holding only an axe.

Once I read this bug I realized what was going on, turned off all my Woodcutting labors with dwarf therapist, and they all dropped their axes, got their gear, and started training.


2012-02-14 01:46

reporter   ~0019494

I had the same problem as Briggs:

On embark I had 3 pesky gorlaks interrupting my dig orders so I dispatched my Axedwarf/Woodcutter to clear them. He did so handily, but after the job was done he didn't pick up his axe from the ground - he seems to have dropped it in the fight - and wouldn't get to work chopping trees. (The save file is at this moment) I tried reassigning woodcutting to another dwarf as well as rotating the military commander, etc.. The axe isn't necessarily stuck as dwarves will move it to a weapon stockpile, as well as equip it thereafter. Still, they refused to chop wood after I enabled woodcutting which left my dwarves without beds :(.

Here's the save:


2012-02-23 17:47

reporter   ~0020577

I struggled with this problem with a woodcutter for a while before I gave up and removed him from the military. However, he wouldn't let go of his wooden training axe and kept using it to chop trees down. Not even sure how that worked, but the resulting slowness in cutting tress was a huge problem for my small fortress' beginning economy.


2012-03-27 15:54

reporter   ~0021801

This bug is related (or even a duplicate) of bug 2959.


2012-06-02 10:49

reporter   ~0022812

Last edited: 2012-06-02 10:51

This bug also causes Miners/Woodcutters/Hunters to refuse to wear their military armor when civilian.
It seems the game creates a separate "uniform" for their civilian tasks, which means they won't use any of the items assigned to their military uniform, such as the axes or armor.


2012-06-08 04:48

reporter   ~0022906

Last edited: 2012-06-08 05:42

34.11 save with miner and woodcutter that claimed armour and refuse to wear it (embark with armour, miner and woodcutter, create squad to replicate):


2012-06-08 05:44


Thanks, Kogut. I've changed the link in your note to point directly to the file, rather than the submit redirect, just in case.


2012-06-11 06:01

reporter   ~0022956

Not sure if its been mentioned, but in 34.11 it seems military wont wear a piece of armor as long as they have something else covering that part.
My dwarves refused to wear steel boots and gloves because they had nice little cloth and leather boots and gloves.


2012-09-16 00:44

reporter   ~0023578

This is not the case for me (dwarves refuse to wear helmets, boots, gauntlets when assigned) as I tried using the 'Replace Clothing' designation and they merely removed their clothing and continued to ignore non-forbidden gear that was sitting in a bin. I feel as though there is something wrong with bins in 34.11 that is causing dwarves to ignore certain items. As far as I know they don't want to bother with gauntlets, boots, and helmets but usually equip everything else, here is my save:


2012-11-21 16:07

reporter   ~0023740

I just had this bug on a new embark... created squad to kill dingoes, when kill order was complete two dorfs dropped their axes where they stood (pretty strange in itself) and subsequent chop tree designations were not fulfilled.

Dorf with woodcutting enabled walked over to the axe and just stood next to it. When squad was disbanded he picked it up and went to work. Can upload save if needed.


2014-07-10 14:55

reporter   ~0025604

I confirm this still happens in 40.01.
Miner who was put in military and assigned armor, won't wear the armor while not in duty, despite his squad being set to "Uniformed when civilian".
As soon as I deactivate the squad the miner rushes to store all his armor in stockpile and get his pick back.
So the civilian equipment (in this case pick) still prevents a dwarf from wearing military uniform at the same time.


2014-08-25 20:41

reporter   ~0029628

Observed pretty much since I've started playing DF. And furthermore, every time I conscript hunters as markdwarves (or crossbowmen, or bowelves, whatever the modding mood of the day is) will result in their dropping the armament they migrated with to pick up new equipment.

Infinite Monkeys

2014-11-27 06:18

reporter   ~0031198

This is a pretty big problem in the early game - it's logical to make your woodcutters, hunters and maybe even miners also serve as your military, but this is currently extremely awkward. The squad has to be created and the weapon manually added when there is a threat, then the weapon unassigned from the dwarf and the dwarf removed from the squad so that they will use that weapon for their job. Even removing the dwarf from the squad alone doesn't work, you have to actually unassign the weapon from them in the equipment menu or they'll ignore it.


2015-12-27 16:42

reporter   ~0034229

My 2 cents on the issue:

It's a conflict between
a) a pick that is assigned via the military equipment screen will never be used for mining, since the game only considers it as a weapon and not a tool
b) a miner dropping his pick when you draft him into the military, because his uniform will tell him to, unless you assign a pick, which brings you back to a)

This is a very, very longstanding bug. Think it dates back to the 2d (no z-levels) version.
I see two possible solutions:
1) change the code of the military weapon assignment to allow the game to recognize assigned military picks as digging tools
2) adding a whole new inventory slot type, "tools", where a dwarf will wear pickaxes and battle axes assigned via the labour list. This would prevent dropping the pick when militarized. A dwarf could then just have 2 picks. One for digging, worn on the tool slot, and one strapped to the body the way weapons are.

I think 2) would probably be easier (require less ripping open of code), but then, I'm no coder, just a dabbling logician


2015-12-28 10:30

reporter   ~0034238

It's definitely not a longstanding bug - well, I mean, it's been around for years but that's more because the military arc was also done years ago.

Prior to the military arc miners and woodcutters used to be the closest thing to a civilian militia we had. If they were near an enemy you could immediately put them in a one-person squad and they'd attack with their pick or axe. This would also use their mining/woodcutting stats to determine their skill so they'd often be really good fighters

That all broke in the military arc

I think the fastest fix is to simply delay the "am i wearing the right equipment?" check until after combat or only when they have no active orders. it wouldn't eliminate all the issues but at least it wouldn't impact the early game as much (when your 'military' is mostly civilian conscripts)


2018-07-17 18:31

reporter   ~0038610

Can confirm this is still present in 0.44.12. Had to queue up axes so that my woodcutters would do their job.

Add Note


Issue History

Date Modified Username Field Change
2010-04-23 02:37 Blah New Issue
2010-04-23 05:25 Areyar Note Added: 0004699
2010-04-23 10:05 user6 Relationship added child of 0000535
2010-04-23 10:17 Blah Note Added: 0004730
2010-04-23 21:06 user6 Relationship added has duplicate 0001478
2010-04-27 08:10 Areyar Note Added: 0005340
2010-05-15 10:09 Inspiration Note Added: 0006728
2010-06-20 02:30 vasiln Note Added: 0008751
2010-06-30 13:45 user6 Relationship added has duplicate 0000523
2010-07-16 09:09 user6 Relationship added has duplicate 0001693
2010-08-03 10:24 user6 Relationship added has duplicate 0002906
2010-08-03 10:25 user6 Note Added: 0011450
2010-09-14 09:37 Hieronymous Alloy Note Added: 0012633
2011-02-28 21:06 user6 Relationship added related to 0000737
2011-02-28 21:39 user6 Summary woodcutter can't use his axe for military; needs a different weapon => Military equipment interferes with civilian equipment (picks/axes/crossbows/quivers)
2011-02-28 21:39 user6 Relationship added related to 0000353
2011-02-28 21:39 user6 Relationship deleted related to 0000353
2011-02-28 21:39 user6 Relationship replaced related to 0000535
2011-02-28 21:39 user6 Relationship added parent of 0002143
2011-02-28 21:40 user6 Relationship added parent of 0002127
2011-02-28 21:40 user6 Relationship added related to 0000680
2011-02-28 21:41 user6 Relationship added related to 0003733
2011-02-28 21:41 user6 Relationship replaced parent of 0003733
2011-02-28 21:41 user6 Relationship added parent of 0004062
2011-02-28 21:42 user6 Relationship added related to 0000110
2011-02-28 21:43 user6 Relationship added related to 0000340
2011-02-28 21:43 user6 Relationship added related to 0000712
2011-02-28 21:45 user6 Relationship deleted parent of 0003733
2011-02-28 22:05 user6 Sticky Issue No => Yes
2011-03-16 06:23 user6 Relationship added parent of 0004236
2012-02-14 01:46 icecon Note Added: 0019494
2012-02-23 17:47 isitanos Note Added: 0020577
2012-03-05 09:05 user6 Relationship added related to 0005300
2012-03-05 09:05 user6 Relationship added related to 0001016
2012-03-05 09:05 user6 Relationship deleted related to 0005300
2012-03-27 15:54 thvaz Note Added: 0021801
2012-03-27 19:46 user6 Relationship added parent of 0002959
2012-06-02 10:49 Rafal99 Note Added: 0022812
2012-06-02 10:51 Rafal99 Note Edited: 0022812
2012-06-08 04:48 Kogut Note Added: 0022906
2012-06-08 05:00 Kogut Note Edited: 0022906
2012-06-08 05:42 user1294 Note Edited: 0022906
2012-06-08 05:44 user1294 Note Added: 0022908
2012-06-11 06:01 Katie Note Added: 0022956
2012-09-16 00:44 MightyRavenDark Note Added: 0023578
2012-11-21 16:07 hermes Note Added: 0023740
2013-09-23 09:53 user6 Relationship added related to 0005300
2014-07-10 14:55 Rafal99 Note Added: 0025604
2014-07-26 06:46 user11 Relationship added has duplicate 0007640
2014-07-26 07:29 user11 Relationship deleted has duplicate 0007640
2014-07-26 07:32 user11 Assigned To => user11
2014-07-26 07:32 user11 Status new => acknowledged
2014-08-09 10:48 user11 Status acknowledged => confirmed
2014-08-25 20:41 chaosvolt Note Added: 0029628
2014-09-25 09:07 user6 Relationship added related to 0008345
2014-11-27 06:18 Infinite Monkeys Note Added: 0031198
2015-12-27 16:42 martinuzz Note Added: 0034229
2015-12-28 10:30 SirPenguin Note Added: 0034238
2017-02-24 09:34 Loci Relationship added has duplicate 0009007
2017-04-12 07:43 Loci Relationship added parent of 0010179
2017-05-10 03:44 Loci Relationship added has duplicate 0010228
2018-07-17 18:31 ArmokGoB Note Added: 0038610
2019-08-13 13:49 Loci Relationship added related to 0008961